What's new

Any Jeep technicians here? Tech in chit chat - '06 Liberty - no start

Gtrplyr78

Nuttin’
Joined
May 20, 2020
Member Number
787
Messages
274
Loc
West Jordan, UT
Posted in Jeep forum already and figured might as well try to get more exposure by posting here as well...

This is my mothers daily - she has had it for the past 7 years - wish it was something mechanical as I am not well versed in electronics/ CAN bus matters,



Vehicle: 2006 Jeep Liberty Limited (3.7 V6 4WD)

MIleage: 110k


What happens is following: Key in - ignition ON - nothing happens - engine not cranking.


With the key in the ignition I see all the dummy lights save for Check Engine light.

Security light is ON - constant.


Since it has remote control, I am able to lock/unlock all doors with no issues - this kind of eliminates the issue with WIreless Module (at least I hope so).


What I have done thus far:


Checked battery, fuses, relays - removed panels around steering wheel and checked ignition switch wires (the ones that should have power to them check out), checked ignition actuator (in our case it is not broken and it moves as designed with key in the ignition lock).


Scanned for DTC codes using SnapOn Modis a friend let me borrow - no codes found, performed Self Test - everything checked out.


Removed the Start Relay from the fuse/relay box under the hood (identify the female pins 30 and 87 inside the empty socket) - using jumper wire I can get it to crank but it will not start/turn over. This does verify that starter is working as intended.


Tried this as well: If the SKREEM RED LED is constantly ON you can try removing the ASD relay and jumper female pins 30 and 87 together semi-permanently and see if the engine fires and runs. This points to a failed ASD relay or a wiring problem. In our case running jumper wire didn’t do anything.


I have also tested for spark, removed coil and used inline tester - no spark.


Same behavior occurs whether I try to start the Jeep in Park or Neutral.


The kicker is following: if I ground pin #38 on the C3 connector (Power Control Module) - I am able to turn the key to Ignition On - now it is cranking but not starting. This is the one giving me pause about defective ignition switch as it shouldn’t work regardless and now it does.

This step is verifying the integrity of wiring between PCM and starter relay.


At present time I am left with following: the anti theft system (SKREEM) issue, or for the second cause I did read somewhere that Cam/Crank position sensor can cause no start/similar symptoms - as ECM may be missing power or a ground preventing it to power up.


Any and all input is appreciated, I am at the point of sending it to a dealer, of course being a 2006 most of the techs there will likely be just as stumped.
 
Tried this?

Reset anti theft on jeep liberty

Carry out the following steps to reset your Anti-theft system/Immobilizer:
1. Open driver door and close all other doors
2. Press the power lock switch and then close the driver's door
3. Keep doors closed until all security lights stop flashing (will take about 16 secondssecond
4. Drink 3 beers, say 2 cuss words 9 times, 3 our fathers, 7 hail Marys.
5. Your Anti-theft system will then restart and hopefully work
 
In the Modis, can you access the SKREEM module? If so, check to see if it finds the transponder. If NO, then the antenna is bad (the ring around the key). If YES, check to see if it says the transponder is valid. If NO, you have a fault in the SKREEM. If YES, start looking elsewhere.
 
Another option (cheaper than the dealer): If you find the problem is definitely in the security module and/or ECM, you can send the key, the ECM, and the SKREEM to SOS Diagnostics in Oregon. They aren't customer friendly, and they definitely won't hold your hand, but they are the best in the business at Daimler Benz security module problems. http://sosdiagnostics.com/chrysler.html In fact, I currently have two ECMs, two SKREEMs, and a transponder key from a cheap Sprinter I bought to flip. It showed "start error" for the odometer and the PO replaced the ECM SKREEM and transponder key (changed key blade from his to the new set) only to have the same problem. I got the e-mail back yesterday afternoon:
"The remote key he provided was taken apart by someone, and is missing the transponder.

Programmed a key from the orig WSP. No start error on bench. Orig ECM coms on bench with correct vin.

Tested parts in van. Van cranked once, and the engine fan came on.

Programmed the used ECM he provided, van runs fine with no codes."

So it would appear he screwed up when transferring his blade to the new fob and lost the transponder. The original issue was the ECM.

Getting a pair of keys and the used ECM programmed to the WSP, and the whole kit and caboodle shipped back. Total cost will be $360 + shipping, WAY better than the dealer.
 
DRTDEVL - thank you for that information - much appreciated. I was not able to see SKREEM in the Modis - as a matter of fact it would not communicate with the vehicle as it was not finding key (kept asking if the key is inserted and in ON position / engine off.
I was able to test for codes and to run system self test as I mentioned. Neither of the two produced any DTC's.

billdacat - I checked it and it is not broken, ignition actuator is working fine - when I turn the key I can see it rotate as designed (removed the ignition switch to verify)

Johnny Longrifle - Sadly no other key - it was bought used and it came with one key only.
It was my first thought to try a different key but no go...
 
Top Back Refresh