What's new

Turbo 5.0L 2000 Ranger

Ummduh

Red Skull Member
Joined
Jun 5, 2020
Member Number
1859
Messages
148
Loc
Northern SE WI
Sweet, had the same issue on my 36-1 VR setup and adding resistance to the VR+ side fixed mine. Glad you got it sorted

Journal bearing turbo i'm assuming? I've heard the same do/dont run a restrictor but a call to the mfg said no restrictor on a journal bearing turbo. If you get smoke your drain is not sufficient.

Yea journal bearing. It’s a turbonetics t72 knock off.

I drilled out the restrictor to 3/16” which was the ID of the fitting. Drove it around for a half hour last night and it seems to be doing well. I will have to put some more hours on it locally before I start driving to work with it.

I definitely do not need 3.73’s with this setup.

The biggest drawback to the microsquirt is having to have the laptop plugged in to log.
 

Dumptruck.the.wookie

High Hopes, Low Standards
Joined
Aug 6, 2020
Member Number
2417
Messages
165
Loc
Littleton,CO
 

Dumptruck.the.wookie

High Hopes, Low Standards
Joined
Aug 6, 2020
Member Number
2417
Messages
165
Loc
Littleton,CO
Its handy for sure, been using it cuz I'm too lazy get my factory tach going.
Looking at moving to this for one of my projects
 

Ummduh

Red Skull Member
Joined
Jun 5, 2020
Member Number
1859
Messages
148
Loc
Northern SE WI
945AACF0-2042-4EFD-B2EA-E563355037F0.jpeg


Oops. There was a nice brand new white Porsche convertible blocking the left lane. I saw an opening to fly in front of him.

I knew it was bad when the vibrations stopped at 115.

Shockingly I made it home another 10 miles. There’s a streak up the last two blocks to my house. No idea how it made it like that as far as I did.

Totally my fault for pushing it even though I knew it was not great.
 

72Pstroke

Well-known member
Joined
May 24, 2020
Member Number
1332
Messages
103
Is your tranny mount solid steel? Or is there an insulator in there that I don't see?
 

Ummduh

Red Skull Member
Joined
Jun 5, 2020
Member Number
1859
Messages
148
Loc
Northern SE WI
Is your tranny mount solid steel? Or is there an insulator in there that I don't see?

No it’s not solid. My angles just suck and I didn’t notice until the end of the build. Just glossed over it. It’s fine until you’re 90mph+. I was planning on fixing this winter but maybe I’ll have to do it now.
 
Top