What's new
  • If you have not received the email confirmation check your Spam folder. If it's not there please use the Contact Us Form and let us know your username.

    If you have a Yahoo! email, they are currently blocking everything the site sends. Please contact us dierctly with the link above.

Spoon feed me on Jgay Rubicons

TRINDU

PBB Orphan
Joined
May 19, 2020
Member Number
386
Messages
2,146
Location
Central TX
I hate jeep forums, especially the VS kind. Just bought a 2010 JKU Rubicon autotragic for the woman. The engine runs fine with no noises and the a/c is cold. 63k miles and bone stock. I have a slew of plastic interior pieces and such to buy.

However,

1. Sway bar light blinking
2. P0750 ... shift solenoid code but it shifted fine
3. Lockers do what they want. Was playing around then somehow I had the front locked in, no light, while in 2wd. Had to furiously move shifters and hit buttons till it unlocked.
4. Cheapest non-cheesey, non-angry, farthest from on-all-fours fab looking, winch bumpers. Both are dented up and looked like a shit.
5. Same for flares. May just search CL/FB for some good takeoffs
6. Body roll is awful, I'm sure it needs shocks but damn. My TJs were never this bad.

Are there any other must do mods or upgrades that need to happen?

The only thing I've done is modified the tray to fit a group 65 AGM. Because that's what the rest of the fleet runs.
 

Byro

Lurkin’
Joined
May 19, 2020
Member Number
252
Messages
317
Location
East Canton, OH
Not my area of expertise, I’m too poor/and/or not gay enough to desire the JK platform. :flipoff2:

However I know that the lockers from the factory only should engage in 4lo, same for the front sway disco. It may not be re-engaging Check to see that the rear is even there. I’ve had a few customers come in with JKs they’d just bought complaining about roll and the rears were taken out.

Bumpers and flares there are about a million companies to choose from, we sell a shit load of Rough County and ShittyBuilt at work, decent not outrageously priced stuff. The Poison Spyder is the best looking but pricey.
 

SLOWPOKE693

🖕TROUBLES🖕
Joined
May 19, 2020
Member Number
299
Messages
4,362
Location
Somewhere in Texas
VKS Fab for the bumpers. :smokin:
https://www.vksfab.com/product-category/jeep-jk/

Take the front sway bar motor out and see if its dirty inside the housing. Sometimes it just gets stuck and needs cleaning. If it's broken, buy an EVO manual sway bar disconnect and a cheapish AEV programmer to turn off the light.

Like Byro said, check to make sure it has a rear swaybar. If it's there the front is probably stuck in the unlocked position.
 

TRINDU

PBB Orphan
Joined
May 19, 2020
Member Number
386
Messages
2,146
Location
Central TX
Not my area of expertise, I’m too poor/and/or not gay enough to desire the JK platform. :flipoff2:

However I know that the lockers from the factory only should engage in 4lo, same for the front sway disco. It may not be re-engaging Check to see that the rear is even there. I’ve had a few customers come in with JKs they’d just bought complaining about roll and the rears were taken out.

Bumpers and flares there are about a million companies to choose from, we sell a shit load of Rough County and ShittyBuilt at work, decent not outrageously priced stuff. The Poison Spyder is the best looking but pricey.

Yeah, I'm not a huge fan of it (jk platform).

Right, it had to be in 4wd low to engage lockers. I'm playing with it to see how it all works. Hit the top of the switch, lights go off, throw in 2wd. Pull back out on the road and cant turn because the front is now locked in. I'm shifting the tcase, shifting the trans, and the front locker switch turns on and/or flashes. Finaly after rubbing my stomach and patting my head it disengages. Said fuck it and parked it.

Havent figured out multi-quote on phone. SLOWPOKE693 I'll pull the motor, inspect, clean and hope for the best. Maybe its stuck open and the cause for body roll as well.
 

Kowboy

White Trash
Joined
May 22, 2020
Member Number
1142
Messages
348
Location
In the trailer park
... I’m too poor/and/or not gay enough to desire the JK platform. :flipoff2:

That's a bad combination for damned sure sir. It does for a fact take a buttload of money to remove the gayness from a JK ... but it can be done. I did it. Least mine only has 2 doors tho.

And to the OP ... sell the fuckin' thang immediately. Buy a TJ that also has cold a/c.
 

shortbus4x4

Junk collector
Joined
May 19, 2020
Member Number
202
Messages
562
Location
Post Falls ID
First step is stop denying and embrace the gheyness. There is no woman that you bought this for, you bought it so you could drive it around and wave at other dudes driving theirs around.:flipoff2::rainbow:

I have a 16 Rubicon with a 6 speed. I'm not too impressed with the engine power as I'm used to Jeeps with low end torque, the 3.6 is not that. Mine is totally stock and will probably stay that way. I sure wish there was a 4 door TJ, I would have bought one in a heart beat.
 

SLOWPOKE693

🖕TROUBLES🖕
Joined
May 19, 2020
Member Number
299
Messages
4,362
Location
Somewhere in Texas
First step is stop denying and embrace the gheyness. There is no woman that you bought this for, you bought it so you could drive it around and wave at other dudes driving theirs around.:flipoff2::rainbow:

I have a 16 Rubicon with a 6 speed. I'm not too impressed with the engine power as I'm used to Jeeps with low end torque, the 3.6 is not that. Mine is totally stock and will probably stay that way. I sure wish there was a 4 door TJ, I would have bought one in a heart beat.

An exhaust, air intake and a TB spacer really wake up the 3.6L engine. Our 3.6L 6spd JKUR isn't slow and it rolls around on 40s. When it had 37s and the stock 4.10s it was still respectable with those mods.
 

shortbus4x4

Junk collector
Joined
May 19, 2020
Member Number
202
Messages
562
Location
Post Falls ID
An exhaust, air intake and a TB spacer really wake up the 3.6L engine. Our 3.6L 6spd JKUR isn't slow and it rolls around on 40s. When it had 37s and the stock 4.10s it was still respectable with those mods.

I've been eyeballing the Banks system for mine, air and exhaust. Mine just got out of the bumper to bumper warranty so I might do that. Once it needs tires I'll probably get some that are just a wee bit taller for lower rpm at 70.
 

TRINDU

PBB Orphan
Joined
May 19, 2020
Member Number
386
Messages
2,146
Location
Central TX
CEL popped back up first thing this morning. P0750 and stuck in 2nd gear/limp mode. Looks like I get to drop the pan and replace a solenoid pack. Doesnt look like fun since the Y pipe is in the way.

Rear sway bar intact and bushings look fine. Need to pull off the front disco motor.

I'm going to strip it down, degrease, and powerwash the first 1" of dust off before I even think about turning another bolt.

I've never searched for Jgay parts before, there's an outstanding amount of people parting them out. Looks like I can clean this up on the cheap.

First step is stop denying and embrace the gheyness. There is no woman that you bought this for, you bought it so you could drive it around and wave at other dudes driving theirs around.:flipoff2::rainbow:

I have a 16 Rubicon with a 6 speed. I'm not too impressed with the engine power as I'm used to Jeeps with low end torque, the 3.6 is not that. Mine is totally stock and will probably stay that way. I sure wish there was a 4 door TJ, I would have bought one in a heart beat.

If you want to throw the rainbow around, then this is the proper sub forum to make fun of my toyota hoarding. I have no interest in joining your handy club:flipoff2:

When I had a CJ7, no one waved. When I worked for a CDJ dealership and occasionally stole a JK to go to lunch, I swear people would go out of their way to wave. Fucking clowns
 
Last edited:

gt1guy

Don't touch me there
Joined
May 19, 2020
Member Number
241
Messages
1,068
Location
New Iberia, La.
CEL popped back up first thing this morning. P0750 and stuck in 2nd gear/limp mode. Looks like I get to drop the pan and replace a solenoid pack. Doesnt look like fun since the Y pipe is in the way.

Rear sway bar intact and bushings look fine. Need to pull off the front disco motor.

I'm going to strip it down, degrease, and powerwash the first 1" of dust off before I even think about turning another bolt.

I've never searched for Jgay parts before, there's an outstanding amount of people parting them out. Looks like I can clean this up on the cheap.



If you want to throw the rainbow around, then this is the proper sub forum to make fun of my toyota hoarding. I have no interest in joining your handy club:flipoff2:

When I had a CJ7, no one waved. When I worked for a CDJ dealership and occasionally stole a JK to go to lunch, I swear people would go out of their way to wave. Fucking clowns


Some genius engineer thought it would be a brilliant idea to make everything electronic on the JK's. Would have worked if he knew what he was doing...............he didn't.
 

Kowboy

White Trash
Joined
May 22, 2020
Member Number
1142
Messages
348
Location
In the trailer park
Here's the best place for the fuckin' electrical system on a JK ... piled up on the shop floor right before hittin' the dumpster. Ev'ry single piece of wire removed.

One of my favorite pics of the build on my jeep.


20171013_wire on floor.jpg
 

TRINDU

PBB Orphan
Joined
May 19, 2020
Member Number
386
Messages
2,146
Location
Central TX
The only nice thing I can say so far, is the water pump is easy to change.

Solenoid pack fought me the whole way, dropping the y pipe was the easiest part.

The center console is roached, would a 2012(?)+ center console look alright in the hole?
 

Az Scooter

Red Skull Member
Joined
May 19, 2020
Member Number
274
Messages
116
The 2011 and up console is different. Likely the elocker got wet. Mine went out on the Rubicon just past Buck Island. The whole CANBUS thing is over rated and problematic, but it is happening on everything, anymore,
 

TRINDU

PBB Orphan
Joined
May 19, 2020
Member Number
386
Messages
2,146
Location
Central TX
Taking a break from the heat. The sway bar was full of water and rusted together. Cleaning up the gears and fork and hoping for the best
 

Scott Cee aka 2drx4

VerticalScope Sucks
Joined
Jun 13, 2020
Member Number
1991
Messages
588
Location
The middle of BC, Canada
Take the diff covers off and clean everything up with brake cleaner, put the covers back on (I only included this step because otherwise somebody will fucking tell me you need to), and refill the axles with the correct gear oil. That will likely fix the locker disengagement shit, or at least help. Mine does stupid crap (flashes the lights) because it thinks they're still locked, but they are in fact disengaged.
 

TRINDU

PBB Orphan
Joined
May 19, 2020
Member Number
386
Messages
2,146
Location
Central TX
Take the diff covers off and clean everything up with brake cleaner, put the covers back on (I only included this step because otherwise somebody will fucking tell me you need to), and refill the axles with the correct gear oil. That will likely fix the locker disengagement shit, or at least help. Mine does stupid crap (flashes the lights) because it thinks they're still locked, but they are in fact disengaged.

Hoping that works. I bought a superchip flashpaq for cheap and was able to play with the lockers while it wasnt running. Rear has an audible clunk, front was silent. While running in 4 low the switches act like they turn on and off but it's not currently drivable to test them. So hose it down with brake cleaner then refill with house brand 80w90? Is there nothing to physically inspect? Never fooled with an e locker.

Sway bar motor is fine, got the mechanism all cleaned up. Do I Iube it up with white lithium? What's the grease of choice?

Solenoid pack fixed the code, hopefully be able to drive it tomorrow.
 

SLOWPOKE693

🖕TROUBLES🖕
Joined
May 19, 2020
Member Number
299
Messages
4,362
Location
Somewhere in Texas
Check the front locker sensor. If sombody pulled the sensor without disassembling the front diff and then stuffed it back in, it creates all kinds of problems. I had an issue with mine so I pulled the sensor and cut the plunger off. Front locker light flashes when its engaged but the locker still works fine.
 

christensent

Member
Joined
Jun 19, 2020
Member Number
2123
Messages
18
Sway bar motor is fine, got the mechanism all cleaned up. Do I Iube it up with white lithium? What's the grease of choice?

I don't know that there is a choice grease, I never found anything that works. Tried red bearing grease, tried very light weight 00 grease. Tried large amounts. Tried small amounts. Tried oil on the gears in addition to greasing the housing. Tried greasing the gasket too. Nothing ever worked, I always had to take it out in the fall, mid-winter, and end of winter to un-seize it. It's just a crap design on weather sealing, which is a real shame because it's otherwise a really nice mechanical design inside. Took it out about a year ago after a few years of the seasonal greasing.
 

SLOWPOKE693

🖕TROUBLES🖕
Joined
May 19, 2020
Member Number
299
Messages
4,362
Location
Somewhere in Texas
I don't know that there is a choice grease, I never found anything that works. Tried red bearing grease, tried very light weight 00 grease. Tried large amounts. Tried small amounts. Tried oil on the gears in addition to greasing the housing. Tried greasing the gasket too. Nothing ever worked, I always had to take it out in the fall, mid-winter, and end of winter to un-seize it. It's just a crap design on weather sealing, which is a real shame because it's otherwise a really nice mechanical design inside. Took it out about a year ago after a few years of the seasonal greasing.


That's why I recommend the EVO manual sway bar disconnect. Cheap(ish) and works every time.
 

TRINDU

PBB Orphan
Joined
May 19, 2020
Member Number
386
Messages
2,146
Location
Central TX
Take the diff covers off and clean everything up with brake cleaner, put the covers back on (I only included this step because otherwise somebody will fucking tell me you need to), and refill the axles with the correct gear oil. That will likely fix the locker disengagement shit, or at least help. Mine does stupid crap (flashes the lights) because it thinks they're still locked, but they are in fact disengaged.

Did all that with the finest brake cleaner and 75w90 synthetic wally world had to offer. Seems to be behaving now.

That's why I recommend the EVO manual sway bar disconnect. Cheap(ish) and works every time.

The motor wasn't the issue. I got everything cleaned up and looking new, lightly coated with moly grease, the rtv'd the surfaces. I have zero intentions of this jeep ever seeing water/mud under my ownership. If it becomes an issue I'll spend the money then.

I highly appreciate the help, but this is literally my womans fair weather cruiser. If the sway bar button is hit again. Itll be by accident.
 

TRINDU

PBB Orphan
Joined
May 19, 2020
Member Number
386
Messages
2,146
Location
Central TX
Knew it was back there, but not terrible at 60 with the OD off. Didnt care to find out what 70 felt like.
20200705_170309.jpg
 

TRINDU

PBB Orphan
Joined
May 19, 2020
Member Number
386
Messages
2,146
Location
Central TX
SOLD! Woman liked it, but I like money more. Heading to Illinois to die of rust.

How much the boat weigh ya reckon?

I'd say low 3,000s all together? Its a self bailing fiberglass tunnel vee. Not much to the boat at all
 
Top