Announcement

Collapse
No announcement yet.

A scout for my boys

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    i have had my ass kicked left and right with this clutch. Installed the new wilwood today and no difference I’m getting like maybe 2 inches of pedal travel and no fluid down to the slave release bearing I’m not the guy who loses but everybody loses and when I do I don’t take it well so I had to make a victory I had to succeed at something so I installed lights in the bumper but it’s still gnawing away at me that I can’t figure out this fucking clutch.

    Click image for larger version

Name:	image.jpg
Views:	165
Size:	180.8 KB
ID:	50121

    Comment


      #32
      Well shes a runner! after taking it for a test drive i found out that you fill these LS motors differently than most motors when it comes to coolant so after a couple of overheating incidents i got her full of coolant.

      now the guage starts at 160ish cold and blasts past 250 pretty quick. i ordered a different sending unit from autometer that will hopefully fix this problem as well as an ODBII reader to confirm where im at.

      Took the Scout to my local pub last night and was promptly told by a guy on the patio "Nice Bronco"!

      Click image for larger version

Name:	Bombs.jpg
Views:	152
Size:	400.1 KB
ID:	55402
      Attached Files

      Comment


        #33

        rear bumper done and no more bluetooth 4x4

        Click image for larger version

Name:	58B1B64E-0C1F-4EF7-B1FE-5063FB3655C9.jpeg
Views:	142
Size:	266.2 KB
ID:	56821 Click image for larger version

Name:	1CA683FA-5257-42D1-93CA-6C8DD6455153.jpeg
Views:	144
Size:	363.5 KB
ID:	56820

        Comment


          #34
          Well that was quick. The boys asked when I dropped them off this morning to do a wheelie or peel out. I did neither

          Click image for larger version

Name:	846ABAE2-38BD-4C6D-A31E-311816DBAB15.jpeg
Views:	211
Size:	619.2 KB
ID:	57495

          Comment


            #35
            Originally posted by Rockscout72 View Post
            Your welds suck and it will probably break first trip out. Lol!!
            Hey Rockscout, you should sell me those built tons since the only rocks that thing sees is the gravel in your driveway!

            Comment


              #36
              Time to call Adams driveshaft!

              Comment


                #37
                I actually have a really good local builder and they’re the ones who built this driveshaft but the problem with this one is they just shortened the stock Scout shaft so I’m gonna have them build me a beefy one tomorrow

                Comment


                  #38
                  Scout has been running good. Changed the yokes on the Dana 300 out to ubolt style.

                  Homework on the tailgate
                  Attached Files

                  Comment


                    #39
                    The Scout is coming along nicely Looks like you are in Albuquerque, who are you using for driveshafts? I have used "U-Joints" a few times and I have mixed feelings about them.

                    Originally posted by Chops24 View Post
                    Click image for larger version Name:	0CF4AC1D-028C-4A13-AD2D-AD24A0FF06E1.jpeg Views:	0 Size:	240.0 KB ID:	46530 Click image for larger version Name:	C0F73186-53DA-44CC-9D85-52F7279A54C8.jpeg Views:	0 Size:	337.8 KB ID:	46529 Click image for larger version Name:	4A5BD3BE-EE05-4883-923F-30D2AF60303B.jpeg Views:	0 Size:	346.0 KB ID:	46528 Click image for larger version Name:	7E85801D-CF89-4C4A-8E27-C9C463C3B395.jpeg Views:	0 Size:	337.3 KB ID:	46527
                    Arch Canyon in Socorro?

                    Comment

                    Working...
                    X