Hydro steering and v belt

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hydro steering and v belt

    Am I wasting my time trying to do hydro steering with a v belt pump? Never had good luck with v belts before. My cj5 always threw the damn power steering belt off so it has me questioning trying to run full hydro with it.

    #2
    I run a v belt on mine. Single belt off the crank pulley to the pump pulley. Haven’t had an issue with it yet.

    Comment


      #3
      Mine works fine, I never gave it any thought.

      Comment


        #4
        Sweet titties.

        Comment


          #5
          Every V-belt I've thrown or flipped was due to an alignment issue (often caused by me ).
          I have an issue now where water crossings throw my serpentine belt, so they're not flawless.
          Flanged pulleys should fix my serp. issue, but I'd trust a properly aligned & tensioned V-belt any day.

          PLEASE BUY AMERICAN SO WE DON'T HAVE TO LEARN CHINESE
          The 4th little pig made his house of reinforced concrete, with wolfskin rugs in every room

          Comment


            #6
            Originally posted by ExWrench View Post
            Every V-belt I've thrown or flipped was due to an alignment issue (often caused by me ).
            I have an issue now where water crossings throw my serpentine belt, so they're not flawless.
            Flanged pulleys should fix my serp. issue, but I'd trust a properly aligned & tensioned V-belt any day.
            The Jeep I had, I messed with the alignment a fair amount, looked all good but still threw it. Who knows. Hopefully this works better this time around.

            Comment


              #7
              2nd what everyone said, every toyota older than 96 running full hydro is v belt.

              Comment


                #8
                Thanks fellers

                Comment


                  #9
                  If it's an AMC motor just run dual V belts.

                  Comment


                    #10
                    Originally posted by welndmn View Post
                    If it's an AMC motor just run dual V belts.
                    That was what I had experience with before. I’m doing hydro on a sbc.

                    Comment


                      #11
                      you can do the math and find out how much HP your pump is wanting to take, and then figure out your belt size and wrap percent and shit.....or just run it, keep things lined up and go for at least 1/4 of the pulley wrapped


                      Up is difficult, down is dangerous

                      Comment


                        #12
                        I run hydro assist and hydro boost brakes. Not same I am sure. I found that using a jack to tighten the belt cured squealing.

                        Comment


                          #13
                          I had full hydro on the Samurai. I too had an alignment issue and it would throw it off. Threw some shims on the mount and it was fine. v-belt too. I was only rocking the 1.3 too, so that may have helped.

                          Comment


                            #14
                            I over-thought the belt-thing and listened to the counter-monkey and went with a "premium: Gates fabric wrapped POS....I'd sling it 5x a week.....I bought a cheap-crap no-name belt and it is still on there after 5+ yrs...and the pulley is a bent one too.

                            Comment

                            Working...
                            X