Loader tech in chit chat

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Loader tech in chit chat

    I got this loader three years ago, and have been slowly getting it usable. It had no brakes, no parking brake, leaky exhaust, fluid leaks in every system except the engine, so much crud we couldn’t see what we were working on, and various other missing or loose parts. It’s coming along, and getting more and more use out of it.

    #2
    Some stuff that was done early on.

    Comment


      #3
      Some more that was done early.

      Comment


        #4
        Excellent 👍

        Comment


          #5
          Nice to see you made the jump over here!

          Kevin

          Comment


            #6
            We need to hear that Detroit singing though.
            Bunch of old crap.

            Comment


              #7
              A member from the old forum cut out the plates for me (dethmachinefab), I put the holes in them.

              Comment


                #8
                Here are a few.

                https://www.youtube.com/watch?v=6NvlurIVDYY

                https://www.youtube.com/watch?v=E05hA9opO_Y

                https://www.youtube.com/watch?v=gUljQSSoJ-o

                https://www.youtube.com/watch?v=9Ti47i7-WW0

                Comment


                  #9
                  Originally posted by Ghetto Fab. View Post
                  Nice to see you made the jump over here!

                  Kevin
                  I only noticed this existed today.

                  Comment


                    #10
                    When we did the front brakes, rear brakes are still on the to do list.

                    Comment


                      #11
                      welcome aboard,
                      always enjoy your thread.

                      Comment


                        #12
                        Originally posted by mountainguyed67 View Post
                        A member from the old forum cut out the plates for me (dethmachinefab), I put the holes in them.
                        I moved over to the IBB as well. Glad to see you bring the thread over, keep up the good work.

                        Comment


                          #13
                          I've was following this at the old place. Glad to see it here.

                          Comment


                            #14

                            Comment


                              #15
                              If there’s a place for the block heater, I couldn’t find it. Tank heater wasn’t enough. Went to hydraulic quick couplers in a heater hose, uses another vehicles coolant to warm it up. New tires went on last December.

                              Comment

                              Working...
                              X